If you see the error message: "Oops, there was an unexpected error while signing up. Please try again or contact help@blueprint.ai for support," follow the steps in this help article to troubleshoot.
Common Cause
This error often occurs because an account with your email address already exists. Many clinicians create accounts to explore Blueprint, then return later but forget they’ve already signed up.
How to Fix
Try logging in instead of signing up:
Go to the login page: https://clinician.blueprint-health.com/login.
Reset your password using your email address.
Log in with your email and new password.
If issues persist:
Our support team is happy to help! Email us at help@blueprint.ai and include:The email address you're attempting to sign up/login with
Whether you successfully reset your password or not
Screenshots of the error messages you receive when both attempting to sign up and when attempting to login